Document/template view issue
Incident Report for signNow
Resolved
This incident has been resolved.
Posted Mar 28, 2023 - 09:03 EDT
Identified
The issue has been identified and we are implementing a fix.
Posted Mar 28, 2023 - 08:59 EDT
Investigating
Some users can experience issues with displaying documents and templates in their accounts. We are currently investigating the case.
Posted Mar 28, 2023 - 08:24 EDT
This incident affected: Web.