Issue with opening documents
Incident Report for SignNow
Resolved
Some users may have experienced issues while opening documents between 19:45 and 20:05 UTC (15:45-16:05 EDT) due to issues with our cloud provider network throughput. Incident is resolved now.
Posted Aug 22, 2019 - 17:45 EDT
This incident affected: Business environment (Web, API) and Enterprise environment (Web, API).