Error on login
Incident Report for signNow
Resolved
This incident has been resolved.
Posted Jan 11, 2024 - 06:59 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2024 - 06:56 EST
Investigating
Users may experience issues with logging into their accounts or signing documents. We are investigating the problem at the moment.
Posted Jan 11, 2024 - 06:36 EST
This incident affected: Web.