AWS Connectivity Issues
Incident Report for SignNow
Resolved
This incident has been resolved.
Posted Aug 31, 2019 - 15:28 EDT
Identified
Due to AWS connectivity issues some users may have experienced with slowly operating services. We will let you know when problem resolved completely.
Posted Aug 31, 2019 - 10:56 EDT
This incident affected: Business environment (Web).